Author Topic: Error when using opc ua driver with codesys  (Read 305 times)

fredz0003

  • Jr. Member
  • **
  • Posts: 56
Error when using opc ua driver with codesys
« on: August 08, 2022, 06:27:41 PM »
I followed the youtube video for opc ua driver and codesys https://www.youtube.com/watch?v=LjXJ5iimfQ0&t=218s
however I am gettting an error when trying to connect to the opc ua server "Connect failed. Error: Endpoint does not supported the user identity type provided.

I realize is an issue with security, but I can't find where to disable it. The youtube video doesn't seem to do any extra configuration in regards to settings.
So I am assuming codesys now enforces the certs, but no sure.
I can use matrikon explorer ua, and accept the quarantined cert in codesys and browse my plc tags.

Any idea what I am doing wrong?

Using codesys 3.5 SP17
EasyPLC 5.10

fredz0003

  • Jr. Member
  • **
  • Posts: 56
Re: Error when using opc ua driver with codesys
« Reply #1 on: August 08, 2022, 07:02:40 PM »
Nevermind I figured it out needed to change device communication defaults. All good now.

EasyPLC_Master

  • Developer
  • Administrator
  • *****
  • Posts: 924
  • Nirtec
    • The EasyPLC Project
Re: Error when using opc ua driver with codesys
« Reply #2 on: August 09, 2022, 03:31:43 PM »
OK! Thank you for your feedback.